iOS no sound after setActive

we integrated jisti-meet to our ios app, but after hangup, there is a red bar at the top.

we tried below disableAudio to remove red bar after handup and enableAudio before rejoining a meeting.
the issue is after rejoin, the participants can not hear each other.

-(void) disableAudio {
//[[RTCAudioSession sharedInstance] setIsAudioEnabled:NO];
//[[RTCAudioSession sharedInstance] setUseManualAudio:NO];
[[AVAudioSession sharedInstance] setActive:NO withOptions:AVAudioSessionSetActiveOptionNotifyOthersOnDeactivation error:nil];
}

-(void) enableAudio {
[[AVAudioSession sharedInstance] setActive:YES error:nil];
//[[RTCAudioSession sharedInstance] setUseManualAudio:YES];
//[[RTCAudioSession sharedInstance] setIsAudioEnabled:YES];
}

What do you do after hangup? Do you get the condeferenceEnded delegate method called?

Hi
here is how it occurs
1 join a meeting ,everything is good ,haveing sound.
2 handup to exit
3 there is another function using AVAudioRecorder to record voide and share to others but it calles [[AVAudioSession sharedInstance]setActive:NO err:&err] at the end.
4 join a meeting again,issus happens,the participants can not hear each other.

the issus should be caused by #3 setActive:NO and we want to know how to fix it in #4.

Could you give us some help ?

Thank you very much.

Have a good day.

hello, could you give us some suggestions please ?

thanks.

HI @frank. To be honest I have no idea how to deal with that. You are interfering with the AVAudioSession which the WebRTC library is using… can you avoid calling setActive:NO in your recorder?

I think I might have solved your problem… by mistake :stuck_out_tongue: Can you please build the SDK with the following patch applied? https://github.com/jitsi/jitsi-meet/pull/3864

Hello
thanks for your help .but there is the issue yet.

below steps will reproduce the issue

  1. join a meeting (thing goes well here), then click handup to exit

  2. other module in same application call below
    AVAudioSession *session = [AVAudioSession sharedInstance];
    [session setActive:NO withOptions:AVAudioSessionSetActiveOptionNotifyOthersOnDeactivation error:&error];

  3. join a new meeting, then participants can not hear each other

hope get your help again

thank you very much.

@saghul
Hello , my friend , just let you know we have fixed the issue with long time ,thanks for your help again.

In addition ,ould you tell me how much we should pay to you and how to pay it ?

No need to pay anything @frank, I’m happy it works for you now!

I am so appreciate for that , may i have your IM or Email address please?

Maybe we need your help or we would have some cooperation in future :grinning:

Thanks for you help again

Have a good weekend.

My email address shouldn’t be hard to find :wink: Feel free to reach out.

Cheers,

1 Like

@saghul
We have another issue need your help , we have found that jitsi use the bigger data traffic than other solutions , for instance ,there are 6 persons in one room last 20mins ,it will cost 600MB data traffic of per person ,

we have tried to find some solutions to decrease data used ,like reduce the resolutions and fps, but seems no help .

Could you give us some help or suggestions?

In addition ,we have read some answers in stackoverflow below:

Do you think that it is possible ?

Hope get your reply and many thanks.

Have a nice day.

In iOS we ignore the resolution constraints and use 720p always. You can change those here: https://github.com/oney/react-native-webrtc/blob/master/ios/RCTWebRTC/VideoCaptureController.m#L4

@frank @saghul I’m not using the same jisti-meet library but I also face the same issue. How to fix this problem?