Janus Gateway - can send not receive

I’m not sure what information will be needed. I am able to see the stream remotely on the web, but the remote view on device is black. In addition I am receiving a VideoTrackAdapter] Mute event for 1 on the remote stream. After digging I realize this is caused by react-native-webrtc not receiving anything and thus muting the stream.

My issue is I can send and attach on the web just fine, so it might be an issue within janus, but I’m trying to rule things out. Right now it might be that the Webrtc is just timing out before first byte is sent.

I can send any/all information when needed/requested.

To hep things along: I am using turn, and this works without janus just fine, but it is needed for group conferencing and other features.

I have tried the echo test with janus and it works perfectly fine. I am using a modified Janus.js that works with react-native-webrtc.

Additionally, I am using the janus video-room test which locks to vp8, which also might the be issue as I am testing this currently on IOS, android will be the next target. However I am not sure if react-native-webrtc supports vp8 in the RTCView on IOS and I can’t find clear documentation on what codecs are supported on what platforms.

I appreciate all help given in advanced.

All tests so far done on iOS 13.2 and higher, as well as safari 13 on web. However while all devices are technically running off local, I am using a turn server to help the connection as the Janus Gateway is remote.

I have solved this. The issue was RTCPeerConnection doesn’t use callbacks that are passed within the function call itself

pc.createAnswer().then(answer
is required to handle the promise, however the js interface I was using used the older method that has since changed in later versions of react native webRTC.

Once the answer was properly sent and configured everything worked smoothly.