App crash on android when add react-native-webrtc into package.json

I am at the very beginning of a project.

I just add below line in package.json

“react-native-webrtc”: “1.75.2”

then run yarn install to download dependency and launch the app in android. the app crash immediately.
android version is 9

Please paste the crash output or there is no way for us to help.

I’m having the same issue, how can I paste the error, it just came the message ‘Keeps Stops’ in the simulator?

{
“name”: “webrtc”,
“version”: “0.0.1”,
“private”: true,
“scripts”: {
“android”: “react-native run-android”,
“ios”: “react-native run-ios”,
“start”: “react-native start”,
“test”: “jest”,
“lint”: “eslint .”
},
“dependencies”: {
“react”: “16.11.0”,
“react-native”: “0.62.2”,
“react-native-webrtc”: “^1.75.3”
},
“devDependencies”: {
@babel/core”: “^7.9.0”,
@babel/runtime”: “^7.9.2”,
@react-native-community/eslint-config”: “^1.0.0”,
“babel-jest”: “^25.3.0”,
“eslint”: “^6.8.0”,
“jest”: “^25.3.0”,
“metro-react-native-babel-preset”: “^0.59.0”,
“react-test-renderer”: “16.11.0”
},
“jest”: {
“preset”: “react-native”
}
}

1 Like

Have you tried adding this to your gradle.properties.
android.enableDexingArtifactTransform.desugaring=false

Also the latest React Native has issues with Flipper causing crashes.
Best to stay with version 0.61.5 for now to be honest.

9 Likes

Getting this when upgrading to RN 0.62.2, I’m guessing it’s the Flipper related crash @8BallBomBom is talking about.

Process: com.webrtcmobile, PID: 8035
    java.lang.NoSuchMethodError: No static method createEgl14([I)Lorg/webrtc/EglBase14; in class Lorg/webrtc/EglBase; or its super classes (declaration of 'org.webrtc.EglBase' appears in /data/app/com.webrtcmobile-rrIxqj9WKHT1QILZDDkBAQ==/base.apk)

You can reproduce in this fork of my minimal example

Have you tried adding what i said to your gradle.properties file?
That should fix the issue as that crash is related to an updated gradle version.

The other crashing issue related to Flipper seems to hit random new and old Android devices.

This solution works for me.

1 Like

Thank you, It works!

1 Like

Thanks for the PR @8BallBomBom!

I just wanted to help isolate the issue since I don’t know too much about android internals. It does seem to be stemming from the react-native-webrtc package, since this workaround isn’t needed for other projects not using this dep.

I’ll probably hold off on updating the example project for a bit in hopes that a fix will be found. The maintainers of this package are awesome btw!

For everyone else, here’s a bit more info:

1 Like

Far as i know it should be fixed with a newer gradle update.
But nothing as of yet.

Facing the same problem.
App crashes on load.

You’re a life saver…thank you it works for after 4 days of trying to to solve it.

1 Like

@ 8BallBomBom thanks this solution also worked for me.

1 Like

Thank you so much. This helped perfectly.

1 Like

Thank you! it worked for me

1 Like

Last night i couldnt sleep because of this,
THANKS Ninja

1 Like