App immediatly crash after installing react-native-webrtc

Hello everyone !
I just created a new app (react 16.11 and react-native 0.62) , installed react-native-webrtc and configure the android part acording to the docs (as i did for an other app that works well) but without even calling any method form the package the app open and close immediatly.

Anyone run into that problem ?

Would be easier to debug if you could provide logs from logcat.
Shouldn’t be more than opening the android project in Android Studio, hooking up the device, launch the app a few times, check the logs for the crash error.

Hi !

thank you for your answer, i find the issue, it was the gradle version ( 6 ) so i just downgrade to 5.5 i it’s working fine !

Thanks again

If you’re experiencing crashing due to using a newer gradle version then you can fix that by adding android.enableDexingArtifactTransform.desugaring=false inside your file.

1 Like

Oh ok nice, thank you very much

This solution work perfectly

How can this work, if this property is experimental and unsupported? The current default value of this property - ‘true’.

I tried your advice, but I got a new error
“Native module WebRTCModule tried to override WebRTCModule.” I made rebuild, but this didn’t help in my case(Any ideas?)

Weird error.
Seems almost like you’re trying to load the module twice.

1 Like

Same issue as here.

1 Like

Don’t link manually, leave it to auto link