Echo cancelation

In the release notes of M.1.75 it says “significantly improves the echo canceling on Android”.
Any idea how to enable it ?
I am running rtcsession on android and there is no echo cancelation at all.
The mediaConstraints I used to create createLocalDescription is as following:
mediaConstraints: {
audio: true, // only audio calls
video: false
}

Thanks advance for any help

It’s enabled by default. What device are you using?

I am using sony xperia z
with android version 9
kernel version 4.4.148
build number 47.2.A.10.107

Also I got these lines in the log cat, it seems AEC is disabled.
2019-10-15 15:29:52.408 2940-3033/com.cirrusproject D/com.oney.WebRTCModule.WebRTCModule: onAddTrack
2019-10-15 15:29:52.411 2940-3006/com.cirrusproject D/com.oney.WebRTCModule.WebRTCModule: peerConnectionSetRemoteDescription() end
2019-10-15 15:29:52.498 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: enableBuiltInAEC(false)
2019-10-15 15:29:52.498 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioEffectsExternal: setAEC(false)
2019-10-15 15:29:52.499 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: enableBuiltInNS(true)
2019-10-15 15:29:52.499 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioEffectsExternal: setNS(true)
2019-10-15 15:29:52.499 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: initRecording(sampleRate=48000, channels=1)
2019-10-15 15:29:52.499 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: byteBuffer.capacity: 960
2019-10-15 15:29:52.500 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: AudioRecord.getMinBufferSize: 3840
2019-10-15 15:29:52.500 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: bufferSizeInBytes: 7680
2019-10-15 15:29:52.516 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioEffectsExternal: enable(audioSession=91625)
2019-10-15 15:29:52.519 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioEffectsExternal: AcousticEchoCanceler: was enabled, enable: false, is now: disabled
2019-10-15 15:29:52.520 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioEffectsExternal: NoiseSuppressor: was enabled, enable: true, is now: enabled
2019-10-15 15:29:52.521 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: AudioRecord: session ID: 91625, channels: 1, sample rate: 48000
2019-10-15 15:29:52.521 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: AudioRecord: buffer size in frames: 3840
2019-10-15 15:29:52.521 2940-3016/com.cirrusproject I/org.webrtc.Logging: WebRtcAudioRecordExternal: startRecording

That explains!

What constraints are you passing to gUM?