iOS build fails with 'WebRTC/RTCMediaStreamTrack.h' file not found

iOS build fails with 'WebRTC/RTCMediaStreamTrack.h' file not found. Same for simulator or device.
It has also failed with 'WebRTC/RTCCameraVideoCapturer.h' file not found. And with 'WebRTC/RTCMediaStream.h' file not found after a pod update.

I use:

  • platform :ios, '11.0' in my Podfile
  • "react-native": "0.63.4"
  • CocoaPods 1.8.4

I did:

yarn add react-native-webrtc
npx pod-install

and it was successful: Installing react-native-webrtc (1.87.2), but trying to run it on the iPhone 12 (14.2) Simulator, or on a device with iOS 12.4.9, results in the above error.

I then separately tried to build and run Same error.
Also tried "Simplest example possible" updated to RN 0.63.3 with the same error.

Any ideas?

I totally misread the CocoaPods version on the installation notice ( IMPORTANT: Make sure you are using CocoaPods 1.10 or higher. - it is in fact the latest version.

So updated to 1.10 and the build was successful.